Back to overview
Downtime
Billink webpage update
Feb 02, 2026 at 09:40pm UTC
Affected services
Billink website
Resolved
Feb 02, 2026 at 10:54pm UTC
Migration finished
Affected services
Created
Feb 02, 2026 at 09:40pm UTC
We are currently working on a platform update for our webpage www.billink.nl
Affected services