Back to overview
Degraded
All Services Down or Degraded
Nov 18 at 01:34pm CET
Affected services
API gateway
Payment sessions
Billink website
Merchant portal
Consumer portal
Mobile Apps
Invoice service
Dispute service
CP service
MFA service
QR service
Resolved
Nov 18 at 01:51pm CET
We have been able to isolate the issues and all the services are again fully functional
Affected services
Created
Nov 18 at 01:34pm CET
Cloudflare Global network issues are impacting our services. We are working on the issue.
Affected services